Kosmor Forum Index
 Search Imprint      SearchSearch     Log inLog in 
 Search Legal      MemberlistMemberlist     ProfileProfile   

No trail from WP movement

 
Post new topic   This topic is locked: you cannot edit posts or make replies.    Kosmor Forum Index -> Bug-Reports
View previous topic :: View next topic  
Author Message
Agnar
Guest





PostPosted: Sun Sep 24, 2006 05:40    Post subject: No trail from WP movement Reply with quote

I have been watching an enemy WP, which has been sitting on a planet. Today that WP jumped, and dissapeared from the planet.

I could not see the trail of the WP, so i assumed that it had simply jumped into an area that i cannot see.

However, on examining another part of the galaxy, i spotted this WP! It had a long jump-trail behind it. I clicked on the map several times, to follow this trail back. It seems to end back on the planet that i was watching, but as i move the map closer to the planet the trail dissapears!

When in the vicinity of the start of the jump, no trail can be seen on the map.
When in the vicinity of the end (or middle) of the jump, a trail CAN be seen.


(I would also like to suggest that when a WP jumps into a non-viewable area, that you can still see any drive trail indicating the direction taken. Though it makes sense not to see and target the WP in a non-viewable area, I feel it should still be possible, in the visible area, to see the disturbance caused by the massive drives)
Back to top
Claudio
Guest





PostPosted: Sun Sep 24, 2006 07:12    Post subject: Reply with quote

I can confirm this....

The trail just stops to continue.
Back to top
Nikoy
Guest





PostPosted: Sun Sep 24, 2006 09:30    Post subject: Reply with quote

O yes! It is logical that we are able to see the disturbance untill it goes out of our radars!
Back to top
Carboneater
Guest





PostPosted: Sun Sep 24, 2006 10:35    Post subject: Reply with quote

Well, Trails are great disturbances, and if we can't see them directly, we can capture their echoes. But the real thing is the missing part of the trail...

Last edited by Carboneater on Mon Sep 25, 2006 18:07; edited 1 time in total
Back to top
Shadowmaster
Guest





PostPosted: Sun Sep 24, 2006 17:48    Post subject: Reply with quote

i have had the same situation happen to me befor as well.
Back to top
Aurion
Member of the House


Joined: 31 Jan 2004
Posts: 591
Location: Alpha Section

PostPosted: Mon Sep 25, 2006 04:48    Post subject: Reply with quote

I noticed the same bug and i can only agree with the previous speakers.
_________________
Member of the House Aurion in the house Ashera
Back to top
View user's profile Send private message Visit poster's website
Carboneater
Guest





PostPosted: Tue Sep 26, 2006 15:18    Post subject: Reply with quote

I've got the same bug happening to me, but strangely,
as I moved my map view, I've seen the trail appear and disapear, depending of if I see or not the jumping WP. It's very strange.
And this trail appear in the SVG. So, the bug may be in the map displaying only.
Back to top
alphabravo
Major


Joined: 15 Feb 2004
Posts: 827
Location: UK

PostPosted: Tue Sep 26, 2006 17:25    Post subject: Reply with quote

yes - i've noticed this bug, and so i use the SVG to trace the tails

i have given it some thought - and it surprises me - i would have thought that for the whole map to be drawn when the Game Processor runs (radars, planet names + colours, WPs and tails) and held locally on the hard drives would be faster than a live script generated map (speaking of experience, where my dot map for the galaxy took a loooong time to be drawn live)

this would mean that when the map script runs it would pass the coordinates of the box, and then this would be drawn from the mastermaps, and just the yellow course line would be drawn, and the arrow showing currently selected part of space


so this sounds like this is not the case, and that maps are, indeed drawn dynamically - or partly so anyway
_________________
Major alphabravo in the house Ashera
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Maelstroem
Commander


Joined: 30 Jan 2004
Posts: 430
Location: Munich, Germany

PostPosted: Fri Sep 29, 2006 07:32    Post subject: Reply with quote

It is a known "clipping-problem".
Trails are always shown correctly on the svg or big png map.
(Indeed, certain parts of the small map are drawn dynamically, the wp-trail belongs to that class of objects).

When I improve the mapping view, I will enhance this.
Also, trails should have the possibility to show a "rerouting-bend", which happens when the warplanet flys to a target and then retreats.

Bye,
Maelstroem
_________________
Commander Maelstroem in the house Nemesis
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    Kosmor Forum Index -> Bug-Reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group